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1.

 

  Product name

 

A

 

dobe® Acrobat® 7.0 for Citrix MetaFrame Presentation Server.

 

2.

 

  Document overview

 

T

 

his document explains how an IT manager can host Adobe Acrobat on a server and have it emulated on  
Microsoft® Windows® client computers that use Citrix MetaFrame. This document assumes that you have a basic 
understanding of the Windows operating system, Citrix MetaFrame, and Adobe Acrobat.

This document also provides information on common troubleshooting issues.

 

3.

 

  References

 

•

 

A

 

dobe developer resources partners.adobe.com/developer/main.html

 

•

 

A

 

dobe documentation about enterprise deployment 
partners.adobe.com/public/developer/acrobat/index_advanced.html

 

•

 

A

 

crobat IT Solutions website on Adobe Acrobat products targeted to the IT professional 
www.adobe.com/products/acrobat/deployment.html

 

•

 

C

 

itrix MetaFrame Presentation Server home page 
www.citrix.com/site/PS/products/product.asp?familyID=198&productID=186

 

4.

 

  Product overview

 

A

 

dobe has validated the remote application execution of Acrobat 7.0 Professional, Acrobat 7.0 Standard,  
Acrobat 7.0 Elements, and Adobe Reader® 7.0 by using Citrix Metaframe Presentation Server, Enterprise Edition.

 

4.

 

 1.  System requirements

 

Y

 

ou can find the system requirements for Acrobat 7.0 products at the following locations:

 

4.

 

 2.  Acrobat 7.0 Professional

 

www

 

.adobe.com/products/acrobatpro/systemreqs.html

 

4.

 

 3.  Acrobat 7.0 Standard

 

www

 

.adobe.com/products/acrobatstd/systemreqs.html

 

4.

 

 4.  Acrobat 7.0 Elements

 

www

 

.adobe.com/products/acrobatel/systemreqs.html

 

4.

 

 5.  Adobe Reader 7.0

 

www

 

.adobe.com/products/acrobat/acrrsystemreqs.html

http://www.adobe.com/products/acrobatpro/systemreqs.html
http://www.adobe.com/products/acrobat/deployment.html
http://www.citrix.com/site/PS/products/product.asp?familyID=198&productID=186
http://partners.adobe.com/developer/main.html
http://partners.adobe.com/public/developer/acrobat/index_advanced.html
http://www.adobe.com/products/acrobatstd/systemreqs.html
http://www.adobe.com/products/acrobatel/systemreqs.html
http://www.adobe.com/products/acrobat/acrrsystemreqs.html
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4.

 

 6.  Tested environments

 

A

 

crobat 7.0 has been tested in the following Citrix environments:

 

•

 

C

 

itrix MetaFrame Presentation Server, Enterprise Edition, Feature Release 3 on Windows Server 2000

 

•

 

C

 

itrix MetaFrame Presentation Server 3.0 on Windows Server 2003 Standard Edition

The environments used for validation were set up in the following ways:

 

•

 

A use

 

r account was set up using Active Directory Domain User Group.

 

N

 

ote:

 

 The Anonymous User profile was not tested.

 

•

 

T

 

he user account was set up on the server with a restricted Common User profile, with Read, Read and Execute, 
and List Folder Contents permissions. These permissions enable the user to operate the computer and save 
documents; the user cannot install programs or make changes to the system files or settings.

 

•

 

T

 

he server machine was running Microsoft Office XP Professional and Standard with Service Pack 2, Internet 
Explorer 6.0, Visio versions 2002 and 2003, Netscape Navigator 7.1, Adobe Photoshop® 7.01, Illustrator® 10.0.3, 
ImageReady® 7.0.1, and McAfee VirusScan Enterprise 7.1.

 

5.

 

  Installing and configuring Acrobat 7.0 products 

 

Y

 

ou must install Acrobat 7.0 by using Add/Remove Programs on the server running Citrix MetaFrame.

 

T

 

o install Acrobat 7.0:

 

1

 

  

 

C

 

hoose Start > Settings > Control Panel > Add/Remove Programs.

 

2

 

  

 

C

 

lick Install.

 

3

 

  

 

D

 

o one of the following:

 

•

 

I

 

f you are installing from a CD, insert the disk, and then click Next.

 

•

 

I

 

f you are installing from an executable file on the network, click Next, and then click Browse to locate the file. 

 

4

 

  

 

C

 

lick Finish.

 

N

 

ote: 

 

After installing Acrobat 7.0, the Acrobat installer may prompt you to restart the server. If you receive this prompt, 
it is strongly recommended that you restart the system.

 

5.

 

 1.  Publishing the application on the server

 

B

 

efore the customer can access an application, it must be published on the server by means of  
Citrix Management Console.

 

T

 

o publish an application:

 

1

 

  

 

C

 

hoose Start > Programs > Citrix > Citrix Management Console.

 

2

 

  

 

I

 

n the Log On to Citrix Farm dialog box, select the server you want to publish to, and then type your  
Citrix Administrator credentials.

 

3

 

  

 

I

 

n the Citrix Management Console dialog box, expand the Applications tree.

 

4

 

  

 

R

 

ight-click Application, and then click Publish Application.
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5

 

  

 

I

 

n the first panel of the Application Publishing Wizard, type a display name (for example, Acrobat) and a 
description of the application (for example, PDF) that you want to appear on the web interface and other client 
interfaces, and then click Next.

 

6

 

  

 

I

 

n the next panel, click the Application option, and then click Browse to select the application you want to publish 
(for example, Acrobat.exe). Then, click Next.

 

7

 

  

 

On the P

 

rogram Neighborhood Settings panel, click Next.

 

8

 

  

 

On the Sp

 

ecify Application Appearance panel, make any changes to the application resolution, and then click Next.

 

9

 

  

 

On the ne

 

xt panel, if you want to enable audio, click the Enable Audio option. Then, click Next.

 

10

 

  

 

On the Sp

 

ecify Application Limits panel, click Next.

 

11

 

  

 

On the Sp

 

ecify Servers panel, in the list, click Citrix Server, and then click Add to move it to the Configured 
Servers list. Then, click Next.

 

12

 

  

 

On the Sp

 

ecify Users panel, if you want to specify users who can run the application, clear the Allow Anonymous 
Connections option, and specify the users you want to allow. Then, click Next.

 

13

 

  

 

On the Sp

 

ecify File Type Associations panel, click Finish.

 

14

 

  

 

T

 

he wizard finishes and the application is published.

 

5.

 

 2.  Basic acceptance tests for Acrobat

 

A

 

fter the installation is complete, you should test the application on a target computer. This section details the tests 
you can perform to ensure that you installed Acrobat successfully.

 

T

 

o verify that the Acrobat plug-ins are loaded:

 

1

 

  

 

Star

 

t Acrobat, and then verify that no error messages appear on the startup screen.

 

2

 

  

 

C

 

hoose Help > About Adobe Acrobat Plug-ins.

 

3

 

  

 

S

 

elect each plug-in listed in the left column; then verify that Yes appears for the Loaded status located on the right 
under File Name.

 

T

 

o check that basic file commands are working correctly:

 

O

 

pen one or more files, and then do the following: 

 

•

 

P

 

age through the files by using the up and down arrows.

 

•

 

P

 

rint the files to a printer on the network.

 

•

 

U

 

se the Save As command to save the files with or without changes.

 

•

 

C

 

hoose Document > Insert Pages. Then insert another file into the document, save the file, and then close the file. 
Reopen the file and verify that the document contains the inserted pages.

 

T

 

o check menu items:

 

S

 

elect each menu item, and then do the following: 

 

•

 

I

 

f a dialog box appears, close it. 

 

•

 

I

 

f a document opens, close it. 

 

•

 

I

 

f a web page opens, close it.
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T

 

o create a test PDF file:

 

1

 

  

 

Star

 

t Acrobat.

 

2

 

  In the File menu, click Create PDF > From File.

3  In the Open dialog box, browse to any Microsoft Word, Excel or PowerPoint file, and then click Open.

4  Verify that the PDF file was created.

To verify viewing a PDF file in a browser:

In Internet Explorer or Netscape Navigator, go to www.adobe.com/products/acrobat/pdfs/pdfaccess.pdf.

5. 3.  Using Acrobat on client computers

Once Acrobat 7.0 is published on the server (see “Publishing the application on the server”), the Citrix MetaFrame 
client computer can establish a connection to it.

To add a new connection:

1  Choose Start > Programs > Citrix ICA Client > Citrix Program Neighborhood.

2  Select Add New ICA Connection to open the Add New ICE Connection wizard; click Next to proceed through 
the wizard.

3  Log into the server running Citrix MetaFrame to use Acrobat 7.0.

To run Acrobat 7.0 by using Citrix Web Interface from a client computer:

1  On the computer you want to use to access Acrobat, point the web browser to the Citrix Server Web portal (for 
example, http://editcitrix.corp.adobe.com).

2  If you have not yet downloaded the Citrix Web Interface client on this computer, you will be prompted to 
download it. Follow the on-screen instructions to download and install this application.

3  Log into the Citrix Web Interface client.

4  In the Web portal site, click the application icon for the Acrobat 7.0 application you want to run.

To access published Acrobat files by using Citrix Program Neighborhood client:

1  Run the installer file ica32.msi on the computer you want to use as the Citrix Program Neighborhood client.

2  Following installation, double-click the Citrix Program Neighborhood icon on the computer desktop.

3  In the File menu, click Custom Connections Settings.

4  In the Connection tab, do the following:

• Verify that the Network Protocol Connection is set to HTTP/HTTPS.

• Verify that the Server Group is set to Primary.

• If you want to add an address list, click Add and follow the on-screen instructions.

• Click OK.

5  On the computer desktop, double-click Add ICA Connection.

6  Set the connection type to Local Area Network, and then click Next.

www.adobe.com/products/acrobat/pdfs/pdfaccess.pdf
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7  On the next panel, do the following:

• Type a description of the ICA connection.

• Verify that the Network Protocol is set to TCPIP/HTTP.

• Click the Server option and type the server name in the text box.

• Click the Published Application option.

• In the list, click the name of the Acrobat application you want to run.

• Click Next.

8  Select a view for the published application, and then click Next.

9  On the Encryption Level panel, click Next.

10  Type your user credentials, and then click Next.

11  Verify that the Windows colors are set to Default, and then click Next.

12  Click Finish.

6.  Removing Acrobat 7.0

To remove Acrobat 7.0:

1  Choose Start > Settings > Control Panel > Add/Remove Programs.

2  Select Adobe Acrobat 7.0 in the Add/Remove list, and then click Add/Remove.

3  Restart the server to ensure that all the appropriate files are removed.

7.  Troubleshooting

7. 1.  Contacting Adobe Technical Support

If you need to contact Adobe Technical Support, please prepare answers to the following questions so that we can 
better assist you:

Note: Adobe developed a series of tests (test matrix) to validate deployment. Adobe Technical Support can assist with 
features and issues that occur in the tested environments. However, Technical Support may not be able to thoroughly verify 
or support issues that occur outside of the tested environments.

1  Which version of the Citrix software are you using?

2  Which version of the operating system is on the Citrix server? Which Service Pack (if any) has been applied to the 
operating system?

3  Which version of the operating system is on the client computer? Which Service Pack (if any) has been applied to 
the operating system? Do these programs meet the environment requirements listed in “Tested Environments” in 
this document?

4  What is the problem statement (for example, “When I do X with Y, Z happens”)? If the problem produces an error 
message, what is the exact wording of the message?

5  Which user profile is logged into the server (for example, Administrator or Power User)? Does the problem occur 
when an Administrator profile is logged into the server?
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6  Which user profile is logged into the client computer (for example, Administrator or Power User)? Does the 
problem occur when an Administrator profile is logged onto the client computer?

7  Can you reproduce the problem when you test the problem on the server? If so, what steps reproduce the problem?

8  What goal are you trying to achieve? Have you been able to achieve this goal in the past? If so, did anything change 
recently in your environment that might be related to the problem?

7. 2.  Known restrictions for Citrix clients

• Issue #1123402: Any Acrobat product with activation (for example, Acrobat Tryout Version or Acrobat Retail) will 
not work in a Citrix or Microsoft Windows Terminal Services (WTS) environment. You must use a copy of the 
licensed Acrobat product (which does not contain activation) in a Citrix or WTS environment.

• Issue #1101277: If Enable Advanced Printing Features is checked On in the Adobe PDF Printer, printing to the 
Adobe PDF Printer will fail. Please uncheck this option under Adobe PDF Printer > Properties > Advanced tab > 
Enable Advanced Printing Features.

• Issue #0640825:  Acrobat PDFMaker and Adobe PDF Printer do not currently check Citrix licensing restrictions. 
Even users who don't have access to the Acrobat application may be able to use Acrobat PDFMaker and Adobe 
PDF Printer.

• Issue #1119086: Files that are stored on a Citrix mapped local drive cannot be converted to PDF by right-clicking 
on that file and choosing Convert To PDF. A run-time error will occur and Windows Explorer will fail.

• Issue #1106816: When Citrix is hosted on Windows Server 2003 and you then access Acrobat from the Citrix Web 
Client as a published application, creating a PDF will fail if the file name is longer than 60 characters.
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